[poky] Kernel recipe naming

Darren Hart dvhart at linux.intel.com
Thu Dec 9 10:33:17 PST 2010


I asked Richard about recipe naming convention this morning. We were pressed for
time, but this is what I took away from the discussion.

For typical packages, the filename typically looks like:

package-name_version.bb

For kernels this gets a bit more complex as it's useful to indicate the source
of the kernel (linaro, omap, etc.) as well as the base kernel version (2.6.33)
and Richard feels it would be nice to indicate in the filename what the
underlying source repository is (_git). (I agree up to the last point, but for
the source repository type, it seems to me if a user needs that much detail
they can open the .bb file and check the SRC_URI.)

So for a linux recipe, naming as follows seems to meet the above:

linux-linaro_2.6.35+git.bb
linux-linaro_2.6.37+git.bb

I mentioned the -stable and -devel tags which he agreed could be useful, how to
integrate them into the naming scheme wasn't clear to me though. Perhaps:

linux-linaro-stable_2.6.35+git.bb
linux-linaro-devel_2.6.37+git.bb

Although to me, stable and 2.6.35 are redundant for this kernel, and something
along the lines of the following is just as informative, and doesn't pollute the
directory listings quite as much (and doesn't have to be renamed when stable
rebases):

linux-linaro_stable.bb
linux-linaro_devel.bb

In any of the above cases, the PV value doesn't seem to be disputed:

PV=2.6.35+git${SRCPV}

or possibly

PV=2.6.35-linaro+git${SRCPV}

Although including linaro in the PV is probably redundant as it's included in
the PN and those are typically reported together IIRC $PN_$PV.

Thoughts?
-- 
Darren Hart
Yocto Linux Kernel



More information about the poky mailing list